OSA installer issues

A place for developers to discuss development of OSA
Post Reply
Message
Author
Automate
Posts: 1691
Joined: Sat Dec 11, 2010 1:44 pm
Location: US

OSA installer issues

#1 Post by Automate » Mon Nov 25, 2013 3:35 am

I've run into a couple of problems with the OSA installer.

1. During the initial install if the installer has any errors or can not start the OSA service at the end of the install it will uninstall everything. This makes troubleshooting the problem more difficult.

2. Recently I made some changes to the Web Server files. Now sometimes the installer detects that the changes have been made and without asking overwrites my new web files with the original ones from the installer. During this re-install it also messes up the OSA INSTALLDIR in the registry.

Is there a way to modify the installer so these don't happen?

User avatar
Mat
Posts: 501
Joined: Thu Aug 09, 2012 2:35 pm
Location: UK

Re: OSA installer issues

#2 Post by Mat » Fri Nov 29, 2013 4:22 pm

Hi Automate,

If i get your meaning then the answer is no not easily. Because windows installers are transactional it know what files should and shouldn't be there hence if they have changed it will put them back to how they should be. If I remember correctly there were some GIT issues relating to making the service more resilient at starting which would resolve the installer issues. In a round about way its not the installers fault as it merely asks the service to start using the normal approach and if the service fails to start then it presumes something has gone wrong and rolls back.

Post Reply