OSA 0.4.8 date and time frozen - viewed in SYSTEM - SOLVED

A place to report bugs and discuss testing
Post Reply
Message
Author
dj-eon
Posts: 89
Joined: Wed Jul 13, 2011 4:03 am
Location: UK

OSA 0.4.8 date and time frozen - viewed in SYSTEM - SOLVED

#1 Post by dj-eon » Sat Mar 12, 2016 11:00 am

Hi.
I've just updated to 0.4.8.
One of my scripts gets triggered at 6pm, but it wasn't working.

When I view the date and time in the SYSTEM, the date is 11th March (yesterday)
and the time is stuck at 16:50:50 PM.

I've powered off my PC and rebooted to see if it changes, but its still stuck at the time above.

Objects are updating with the correct date and time, and generally everything is working except scripts that look at the time of day.

Sorry if this has already been posted. I didn't find it elsewhere.
Thanks,
Ian.

dj-eon
Posts: 89
Joined: Wed Jul 13, 2011 4:03 am
Location: UK

Re: OSA 0.4.8 date and time seem to be stuck - viewed in SYS

#2 Post by dj-eon » Sat Mar 12, 2016 1:53 pm

Ok, I forgot to add
"event-scheduler = ON"
to the MySQL .ini file

I'll leave this thread here rather than delete it. I'm sure this will happen to someone else.

The location of the ini file wasn't obvious. On this occasion it was located in:
C:\ProgramData\MySQL\MySQL Server 5.7\

Vaughn
Site Admin
Posts: 1432
Joined: Thu May 13, 2010 2:17 pm

Re: OSA 0.4.8 date and time frozen - viewed in SYSTEM - SOLV

#3 Post by Vaughn » Sun Mar 13, 2016 1:07 am

The service should be running that scheduler command every time it starts.

For that to work though, the OSA MySQL user must have super privileges. Maybe you could verify that in Workbench. It is possible the Install script failed to grant the super privileges.

There are known issues surrounding MySQL being able to grant it via command line.

If that is the case though, I will leave a Git issue opened on it, etc.


Vaughn

dj-eon
Posts: 89
Joined: Wed Jul 13, 2011 4:03 am
Location: UK

Re: OSA 0.4.8 date and time frozen - viewed in SYSTEM - SOLV

#4 Post by dj-eon » Tue Mar 15, 2016 1:13 pm

I have MySQL workbench. I looked into it on that first.
It wasn't enabled, but switching it on in workbench wouldn't work. After checking the option, you go back to it and its disabled again.

In the end I just looked around for the ini file and added it manually.

This PC originally had osa 0.4.5 with MySQL 5.6 on it.
I uninstalled both, but I know MySQL can leave stuff behind.

I suspect a clean install of windows wouldn't have had any issues.

Vaughn
Site Admin
Posts: 1432
Joined: Thu May 13, 2010 2:17 pm

Re: OSA 0.4.8 date and time frozen - viewed in SYSTEM - SOLV

#5 Post by Vaughn » Tue Mar 15, 2016 2:20 pm

You can't set the gloabal scheduler in Workbench (it does not stick), I meant just check that the OSA user account has Super-Privileges in workbench, so Service could start it (not that you need it once you modify the MySQL.ini)

Vaughn

Post Reply