[Official Thread] XBMC Plugin Support Thread

Discussion and support for individual OSA plugins
Message
Author
User avatar
bwoodworth
Site Admin
Posts: 1563
Joined: Tue May 04, 2010 6:49 am
Location: California

[Official Thread] XBMC Plugin Support Thread

#1 Post by bwoodworth » Tue Jan 03, 2012 12:15 am

This thread will serve to support the XBMC plugin.

Current features include:

- Ability to play/pause/stop/ffw/rew video
- Receive events when playback starts and stops

This plugin will create a XBMC plugin object which doesn't have any properties. You must manually create XBMC SYSTEM objects for each instance of XBMC you wish to have control over. Also, you must enable control of XBMC over HTTP with XBMC itself before this plugin will work. Once that is set up, you must set the IP and Port properties of the object in order to control it and receive notifications. If you set up a username and password in XBMC you must set those properties as well.

Feel free to post any questions you may have.
Brian

AlexSG
Posts: 47
Joined: Sat Dec 03, 2011 7:18 pm

Re: [Official Thread] XBMC Plugin Support Thread

#2 Post by AlexSG » Tue Jan 03, 2012 8:55 pm

Wow, this is going to be sweet.

Qu3uk
Posts: 2
Joined: Thu Feb 23, 2012 4:51 am

Re: [Official Thread] XBMC Plugin Support Thread

#3 Post by Qu3uk » Thu Feb 23, 2012 4:55 am

Is the source for this going to be released by any chance?

User avatar
bwoodworth
Site Admin
Posts: 1563
Joined: Tue May 04, 2010 6:49 am
Location: California

Re: [Official Thread] XBMC Plugin Support Thread

#4 Post by bwoodworth » Thu Feb 23, 2012 9:00 am

It is now in the repository
Brian

Qu3uk
Posts: 2
Joined: Thu Feb 23, 2012 4:51 am

Re: [Official Thread] XBMC Plugin Support Thread

#5 Post by Qu3uk » Thu Feb 23, 2012 9:33 am

Thanks, I'll check it out later.

User avatar
bwoodworth
Site Admin
Posts: 1563
Joined: Tue May 04, 2010 6:49 am
Location: California

Re: [Official Thread] XBMC Plugin Support Thread

#6 Post by bwoodworth » Sat Mar 24, 2012 7:58 pm

New version of the XBMC plugin posted to support the latest version of XBMC, Eden.
Brian

hellow
Posts: 3
Joined: Wed Jun 13, 2012 11:05 am

Re: [Official Thread] XBMC Plugin Support Thread

#7 Post by hellow » Wed Jun 13, 2012 11:11 am

This looks cool.

Do you have any videos for it in use?

My plan is to hook up a camera to osa and and if someone rings the doorbell the a notification is sent to xbmc with a video stream. Do you know if that is possible?

User avatar
bwoodworth
Site Admin
Posts: 1563
Joined: Tue May 04, 2010 6:49 am
Location: California

Re: [Official Thread] XBMC Plugin Support Thread

#8 Post by bwoodworth » Wed Jun 13, 2012 4:18 pm

I am currently only using it to turn my lights on and off when a video is stopped or started. I have not done any testing of making XBMC start playing a video stream. Have you been able to do this any other way like through the XBMC web service? If it is at all possible to do by sending some kind of command through the web service then we can definitely add support into OSA to make this work.
Brian

vsboost
Posts: 9
Joined: Fri Aug 31, 2012 10:50 pm

Re: [Official Thread] XBMC Plugin Support Thread

#9 Post by vsboost » Fri Aug 31, 2012 10:59 pm

bwoodworth wrote:I am currently only using it to turn my lights on and off when a video is stopped or started. I have not done any testing of making XBMC start playing a video stream. Have you been able to do this any other way like through the XBMC web service? If it is at all possible to do by sending some kind of command through the web service then we can definitely add support into OSA to make this work.

Hi There,

Could you please tell me how you did this exactly, i am trying to accomplish the same thing.

Also not sure if i have the plugin working correctly as i get
----------------------------------------------------------------

09/01/2012 04:55:26.847 PM - Running interface
09/01/2012 04:55:26.931 PM - Creating new XBMC System connection: MY XBMC - 192.168.1.65
09/01/2012 04:55:26.962 PM - EventListener captured event : ConnectionSuccessful - xbmc_json_async.System.XEventListener - 192.168.1.65
09/01/2012 04:55:36.967 PM - Checking MY XBMC - True
09/01/2012 04:55:46.970 PM - Checking MY XBMC - True
09/01/2012 04:55:56.971 PM - Checking MY XBMC - True
09/01/2012 04:56:06.987 PM - Checking MY XBMC - True
09/01/2012 04:56:16.986 PM - Checking MY XBMC - True
------------------------------------------------------------------

But dont get anyting in the log to show if i press STOP or PLAY within XBMC,
In Tools --> Objects the state of XBMC SYSTEM always shows playing even if hit update to refresh the screen.

Any help would be appreciated.

User avatar
bwoodworth
Site Admin
Posts: 1563
Joined: Tue May 04, 2010 6:49 am
Location: California

Re: [Official Thread] XBMC Plugin Support Thread

#10 Post by bwoodworth » Mon Sep 03, 2012 9:13 am

It sounds like you have it set up correctly since you are receiving the connection successful event. Have you set up XBMC to be able to be controlled via HTTP? You don't see any new logging when you play or stop a video?
Brian

Post Reply