Page 1 of 2

Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 12:55 pm
by Synthesis
09/26/2014 03:24:24.573 PM - Found my Object: CM11A
09/26/2014 03:24:40.073 PM - COM Port = 3
09/26/2014 03:24:40.114 PM - Poll Rate = 120
09/26/2014 03:24:40.166 PM - Learning Mode = True
09/26/2014 03:24:40.233 PM - Error in InitializePlugin: Retrieving the COM class factory for component with CLSID {2F1818FA-BFAA-11D2-BAC4-006097C0E8C9} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).


I have registered cm11a.ocx without issue, and restarted both the service and the computer.

I am unable to get it to communicate at all with the CM11a without this error.

Alternative software works just fine, such as Home Control Assistant.

This is a Windows 8.1 system running on a Zotac 1.6 Atom N330 system.

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 1:46 pm
by Automate
32 or 64 bit Windows?

Did you make sure any other software or services that may be using the CM11a are stopped?

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 2:35 pm
by Synthesis
Automate wrote:32 or 64 bit Windows?

Did you make sure any other software or services that may be using the CM11a are stopped?
Yes. Everything else that would be using the com port is off or uninstalled....

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 2:37 pm
by Automate
32 or 64 bit Windows?

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 2:48 pm
by Synthesis
Sorry. On my phone and missed that part.... 64 bit...

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 5:38 pm
by Automate
I don't think anyone has used the CM11A OSA plugin with 64 bit Windows. Does Home Control Assistant work with the CM11A on a 64 bit OS?

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 6:00 pm
by Synthesis
It does... I just dont have the disposable income to pay for hca...

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 6:09 pm
by Automate
The issue with both the CM11A and CM15A plugins is that they use old X10 dll/ocx. User kherron was able to get the CM15A /dll working with 64 bit Windows here http://www.opensourceautomation.com/php ... -t307.html

Don't know if something similar is possible with CM11A / ocx.

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 6:16 pm
by Synthesis
Would installing a 32 bit os resolve the issue?

Re: Error in CM11a Plugin: 80040154 Class not registered

Posted: Fri Sep 26, 2014 6:18 pm
by Automate
Yes, the plugin works on 32 bit Windows.