Need help getting Z-Wave working in OSA 0.4.5 (solved)

Post Reply
Posts: 89
Joined: Wed Jul 13, 2011 4:03 am
Location: UK

Need help getting Z-Wave working in OSA 0.4.5 (solved)

#1 Post by dj-eon » Thu Jun 04, 2015 6:47 am

Hi again.
I've installed OSA 0.4.5, I'm also using the latest Z-Wave 0.6.0, but I cannot for the life of me get it to work.
I'm using an Aeon S2 USB stick which still works fine when I boot into my OSA 043 partition (Win7 x32).

I have tried in Win7 x32 and x64, but after entering the port number, restarting the service it just will not work.
BTW, my goal is to operate in x64, but I will settle for x32 If I have to.

OZWForm.exe is working, and all my z-wave devices appear fine in that on both versions of Windows.

I've set the port number in OSA, but the home ID never appears.

This error appears in server logs under error:

System.TypeLoadException: Could not load type 'System.Runtime.CompilerServices.IAsyncStateMachine' from assembly 'mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089'. at OSAE.Zwave.Zwave.RunInterface(String pluginName) at OSAE.OSAEPluginBase.RunInterface(String pluginName) at OSAE.Plugin.RunInterface()

This error is exactly the same on Win7 x32 and x64.

Well after further investigation, the reason it was not working was completely my fault.
After installing some relevant Windows Updates, it has started working.

A bit embarrassing, but I thought I'd share this anyway.


Post Reply