Powershell Scripting and 0.4.5

Ask and answer questions related to any type of OSA scripting.
Post Reply
Message
Author
volfan6415
Posts: 175
Joined: Sun Jun 08, 2014 9:24 am

Powershell Scripting and 0.4.5

#1 Post by volfan6415 » Tue May 12, 2015 12:32 pm

None of my powershell scripts appear to be running under .4.5. I have downloaded and installed the powershell plugin from the website. The powershell logs are empty?

Where do i need to start looking to debug this?

Vaughn
Site Admin
Posts: 1432
Joined: Thu May 13, 2010 2:17 pm

Re: Powershell Scripting and 0.4.5

#2 Post by Vaughn » Tue May 12, 2015 1:01 pm

Sadly I have never used the plugin and never looked at a single PS script to see how it even interacts with OSA. Matt put that in I believe, and I am not sure if there is anyone who can work on it available.

Hopefully someone is willing to specialize in it as I don't think I can't get to it for a while. I know that is important though, so I will do what I can if no one else will.

Vaughn

volfan6415
Posts: 175
Joined: Sun Jun 08, 2014 9:24 am

Re: Powershell Scripting and 0.4.5

#3 Post by volfan6415 » Tue May 12, 2015 1:10 pm

I am willing to start looking into it. I assume the powershell code that is on GIT is the most update code?

Zach

volfan6415
Posts: 175
Joined: Sun Jun 08, 2014 9:24 am

Re: Powershell Scripting and 0.4.5

#4 Post by volfan6415 » Tue May 12, 2015 2:18 pm

Ok so my fix turned out to be an easy one and now my powershell scripts are running again. The powershell object type was not set to be owned by the power shell object. Once I changed the owernship everything started working again as it should.

Now i don't know if this is a problem with my setup only? Or if something is not quite right in the powershell plugin installer?

Vaughn
Site Admin
Posts: 1432
Joined: Thu May 13, 2010 2:17 pm

Re: Powershell Scripting and 0.4.5

#5 Post by Vaughn » Tue May 12, 2015 4:42 pm

That sounds right. Back in the day, we had to set the owner manually on all object_types. Many plugins were modified to do that automatically. So the PS plugin needs the some attention. I am getting behind on even opening ticket for the work I have done over the past few days, but will try to remember to document this needed change.


Glad you got it going.

Vaughn

User avatar
kherron
Posts: 646
Joined: Mon Dec 05, 2011 10:44 am
Location: Jacksonville, Fl.
Contact:

Re: Powershell Scripting and 0.4.5

#6 Post by kherron » Wed May 13, 2015 6:17 am

We can create an Issue on Git if that will help!

Vaughn
Site Admin
Posts: 1432
Joined: Thu May 13, 2010 2:17 pm

Re: Powershell Scripting and 0.4.5

#7 Post by Vaughn » Wed May 13, 2015 6:47 am

I like git issues, so feel free in general. I opened one just now for this though.

Thanks,
Vaughn

Vaughn
Site Admin
Posts: 1432
Joined: Thu May 13, 2010 2:17 pm

Re: Powershell Scripting and 0.4.5

#8 Post by Vaughn » Wed May 13, 2015 10:51 am

So I opened #261 for this issue, I also just worked it, uploaded the changes and closed the ticket.

I did not test this though, but the ownership code is in several plugins now and I just had to change the name of the object_type, so it should be ok.


Vaughn

Post Reply