Search found 1429 matches

by Vaughn
Fri Sep 28, 2018 10:23 am
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

This is just an FYI update, separate from the REST api stuff. Screens allows the simulation of sensor data. In my test of Screens, I was clicking on a DS10A sensor. Sensors do not have methods, so the REST call adding a Method.Queue entry does nothing. In the main screens application, when you click...
by Vaughn
Fri Sep 28, 2018 9:03 am
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

I modified the logging to give me a little more info: I am having some success, here is my logs now: 09-28 11:57:49.17 INFO Security System Security Key found: oemspial9uzpgzl8 (16 bytes) 09-28 11:57:49.16 INFO Security Checking if System Security Key exist 09-28 11:57:49.16 INFO Security REST API K...
by Vaughn
Thu Sep 27, 2018 1:07 pm
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

I took the required properties off and restarted Rest, nothing populated still Then I used the two keys you posted and I get a size error running the web screen still, but a different error: Source: System.Web Message: Exception of type 'System.Web.HttpUnhandledException' was thrown. Inner Exception...
by Vaughn
Wed Sep 26, 2018 10:07 am
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

On my test machine, I get the log entries: 09-26 13:02:37.31 INFO Security System Security Key found. 09-26 13:02:37.30 INFO Security Checking if System Security Key exist 09-26 13:02:37.30 INFO Security REST API Key found. 09-26 13:02:37.28 INFO Security Checking if REST API Key exist but all of th...
by Vaughn
Wed Sep 26, 2018 9:45 am
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

The service was not started on my dev box, and I thought that might be part of it, so I enabled it and tried to start it, but then I get this error in the system logs: System.ServiceModel.AddressAccessDeniedException: HTTP could not register URL http://+:8732/api/. Your process does not have access ...
by Vaughn
Wed Sep 26, 2018 9:33 am
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

OK, so I got all the property type loaded, but I think it has a problem with the property being null still. I think it is in: private static string ivString = OSAE.OSAEObjectPropertyManager.GetObjectPropertyValue("System", "SecurityKey").Value; This property was null, but when I tried to put a value...
by Vaughn
Tue Sep 25, 2018 6:15 pm
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

I am missing all of that, but I have the email with the SQL in it, so I will get it all applied and test again.

Thanks,
Vaughn
by Vaughn
Tue Sep 25, 2018 1:00 pm
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

I think that key stuff is for REST and the website does not use rest, I commented out the REST key code and it runs, so not sure if it should be in there. The API in there is current and it goes into that subroutine... Edit: Also, the other parts of the website were working, this code/error was only...
by Vaughn
Sat Sep 22, 2018 9:14 pm
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

I am having an error on loading web screens. I don't even have a screen setup on the test, which may be related. I ran out of time testing and have a head ache, so I can investigate more, but thought you might recognize the code and have some advice.
error.png
error.png (136.12 KiB) Viewed 852 times
by Vaughn
Wed Sep 19, 2018 2:52 pm
Forum: Developers
Topic: 049 tracking thread
Replies: 128
Views: 18161

Re: 049 tracking thread

It is pretty much a done deal now. I think we have to make MySQL 8 a requirement. I have already upgraded my test machine to 8.0 fixed a few issues and am back to building out my new 5th wheel setup. I ran into some data issues, like on the StateImage control the graphics fields where using the file...