Search found 105 matches

by winger
Wed May 22, 2013 7:11 am
Forum: Jabber / Email
Topic: Receive email
Replies: 2
Views: 1937

Receive email

Is there a way to have osa receive email or text messages and respond? For example, I don't have a smart phone. Say I have a thermostat controlled by osa. Could I send a text message or text message to osa to set the temperture. Or request osa to send back the current temperature reported by the the...
by winger
Fri Apr 26, 2013 12:28 pm
Forum: Scripting
Topic: Named scripts not workting?
Replies: 9
Views: 1930

Re: Named scripts not workting?

I see. How about the case question. Is it actually case insensitive?
by winger
Fri Apr 26, 2013 8:18 am
Forum: Scripting
Topic: Named scripts not workting?
Replies: 9
Views: 1930

Re: Named scripts not workting?

Oh, I can't delete a match it there is a script attached. Cant delete a pattern if there is a match or a script attached. It makes sense that you cannot delete a pattern if there is a script attached, but I don't see why you cannot delete a match if there is a script attached. If you have several na...
by winger
Fri Apr 26, 2013 8:05 am
Forum: Scripting
Topic: Named scripts not workting?
Replies: 9
Views: 1930

Re: Named scripts not workting?

Yes, I already confirmed the change was persisted. I was not sure I set this up correctly. Does the command I specify have to match the pattern or do I need something in the Match. My command is "Door opened" which is the pattern name. I added these to the Match list "Door Opened", "DOOR OPENED" and...
by winger
Fri Apr 26, 2013 6:35 am
Forum: Scripting
Topic: Named scripts not workting?
Replies: 9
Views: 1930

Re: Named scripts not workting?

I know nothing about mysql. But I tried this. Specifically the change is "SELECT script_id" is changed to "SELECT s.script_id". I was able to change that with mySQL bench. But no change in functionality. I think that is correct syntax but I am not positive. Any other idea what my problem may be? Fro...
by winger
Thu Apr 25, 2013 4:37 pm
Forum: Scripting
Topic: Named scripts not workting?
Replies: 9
Views: 1930

Named scripts not workting?

I am trying to send a command from another prorgam. The command is c:\program files\osa\osaservice.exe "Named-script" This worked in 3.9 and I have not tried it since. Named scripts changes so I assume I have something wrong. There was mentioned in the 4.2 released thread about a problem with named ...
by winger
Tue Apr 23, 2013 10:32 am
Forum: C11A/CM15A/CM17A
Topic: timing problems with cm15a
Replies: 8
Views: 3102

Re: timing problems with cm15a

cm15a.
by winger
Tue Apr 23, 2013 10:19 am
Forum: C11A/CM15A/CM17A
Topic: timing problems with cm15a
Replies: 8
Views: 3102

Re: timing problems with cm15a

It seems like a problem the could be handled in the plugin itself. Somehow handle a command to cycle on/off within the plugin. Maybe methods 'siren on' and 'siren off' and the plugin does the work. I guess I don't know enough about osa to know if this is possible. The plugin would need to use a thre...
by winger
Tue Apr 23, 2013 8:36 am
Forum: C11A/CM15A/CM17A
Topic: timing problems with cm15a
Replies: 8
Views: 3102

Re: timing problems with cm15a

Yes, I have some hand held 8 channel controllers and I can control it with that too. But I am setting up a security system and I need osa to turn a siren on/off. I could use some stand alone sirens and hard wire them to relays, but I had a couple of these and it's nice to have more than one in diffe...
by winger
Tue Apr 23, 2013 7:49 am
Forum: C11A/CM15A/CM17A
Topic: timing problems with cm15a
Replies: 8
Views: 3102

timing problems with cm15a

I am using the cm15a for x10. I am trying to use the x10 power horn as a siren. The documentation says to turn the channel on and off contiuously and the siren will sound and stop shortly after you quit. I have gotten this to work, but I cannot get osa to send the on/off consistanly fast enough for ...